1000. A+B Problem

时间限制 1000 ms   内存限制 128 MB

Calculate a+b

输入数据

Two integer a,b (0<=a,b<=10)

输出数据

Output a+b

样例输入

复制
1 2 · \n

样例输出

复制
3 \n

样例说明

Q: Where are the input and the output? A: Your program shall always read input from stdin (Standard Input) and write output to stdout (Standard Output). For example, you can use 'scanf' in C or 'cin' in C++ to read from stdin, and use 'printf' in C or 'cout' in C++ to write to stdout. You shall not output any extra data to standard output other than that required by the problem, otherwise you will get a "Wrong Answer". User programs are not allowed to open and read from/write to files. You will get a "Runtime Error" or a "Wrong Answer" if you try to do so. Here is a sample solution for problem 1000 using C++/G++:

#include <iostream>
using namespace std;
int  main()
{
    int a,b;
    cin >> a >> b;
    cout << a+b << endl;
    return 0;
}

It's important that the return type of main() must be int when you use G++/GCC,or you may get compile error. Here is a sample solution for problem 1000 using C/GCC:

#include <stdio.h>

int main()
{
    int a,b;
    scanf("%d %d",&a, &b);
    printf("%d\n",a+b);
    return 0;
}

Here is a sample solution for problem 1000 using JAVA: 

import java.io.*;
import java.util.*;
public class Main
{
            public static void main(String args[]) throws Exception
            {
                    Scanner cin=new Scanner(System.in);
                    int a=cin.nextInt();int b=cin.nextInt();
                    System.out.println(a+b);
            }
}

Another Java program for this problem:

import java.io.*;
import java.util.*;

public class Main
{
    public static void main (String args[]) throws Exception
    {
        BufferedReader stdin = 
            new BufferedReader(
                new InputStreamReader(System.in));

        String line = stdin.readLine();
        StringTokenizer st = new StringTokenizer(line);
        int a = Integer.parseInt(st.nextToken());
        int b = Integer.parseInt(st.nextToken());
        System.out.println(a+b);
    }
}

Here is a sample solution for problem 1000 using python2: 

# python2  tell the judge system using python2, default is python3
a=[]
for x in raw_input().split(): 
    a.append(int(x)) 
print sum(a)

Here is a sample solution for problem 1000 using python3: 

a=[] 
for x in input().split():
    a.append(int(x))
print(sum(a))

提交

请先 登录

Source

POJ

© 2024 FAQs Contact About